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 Quick Links & Text References 

 Starting Visio 

 General Drawing Creation Procedures 

 General Guidelines 

 Setting Diagram Theme 

 Setting Diagram Orientation 

 Adding Shapes to Diagram 

 Aligning Shapes 

 Adjusting Shape Spacing 

 Adding Text to Shapes 

 Connecting Shapes 

 Adjusting Connectors 

 Adding Line Labels 

 Adding Floating Text 

 Multiple Page Flowcharts 

 Sprucing Up Your Drawing 

 Saving a Visio Drawing 

 Printing a Visio Drawing 
 

 
 
 

 
 

 
 
 

 
 

 

 Starting Visio  

 Click the Start Button, choose (All) Programs, click on 
Microsoft Visio (may be in the Office folder) 

 If necessary, select the File tab and choose New in the left 
column of items. 

 Choose (double-click) the Basic Flowchart template 

 The Basic Flowchart template will appear on the left side 

of the screen, providing access to all your favorite 
flowchart symbols.   

 A new document appears on the right. You may want to 

change the zoom (View tab) to 100% to get a better view. 
 You can also change the zoom level by holding the 

Ctrl key down while moving the scroll wheel on the 
mouse. 
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 General Drawing Creation Procedures 

1. Set the diagram theme 
2. Set diagram orientation 
3. Add shapes to diagram 

4. Label Shapes 
5. Connect shapes 

6. Add remaining labels and symbols 
7. Save diagram 

 

 

 General Guidelines 

 Don’t forget the undo button. Visio has multiple levels of 

undo. 

 To select multiple objects: 

 Drag a box around the objects (you must completely 
surround the objects—objects that are merely 
touched are not selected). 

 Shift-click an object to add it or remove it from the 
list 

 

 

 Setting Diagram Theme 

 Visio starts out creating boxes with a blue background 

 If you wish, you can change the color scheme Visio uses 

for this diagram. 

 Click the Design tab and choose a theme from the 

Themes group 

 Tip: place a couple of objects on the form so you can see 

the effects of changing to a theme. 

 The Simple theme results in a plain, black-and-white 
flowchart 

 

 

 Setting Diagram Orientation 

 Select Design tab, Page Setup group 

 Use the Orientation button to designate Portrait or 

Landscape orientation  

 Usually use portrait for flowcharts, but not always 
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 Adding Shapes to Diagram 

 Drag shapes from template to diagram 

 Use handles to resize shapes 

 To quickly copy custom sized shapes: 
 Select shape to copy (click it) 

 Ctrl-drag shape to new location 
 Repeat as many times as desired 

 

 

 

 Aligning Shapes 

 Visio displays alignment guides to help you align shapes 
both vertically and horizontally when you drag a shape 

 The lines through the center of the shapes help you align 
shapes. 

 The double-headed arrows designate the shapes are 
spaced evenly. 

 Note if the background grid doesn’t appear and you’d like 

it to, choose the View tab, Show group, Grid option 
 

 Option 2 

 You can also realign shapes after they’re already on the 

form.  

 Select shapes to align 

 First select the master shape—the one the others 
should align to. 

 The first shape you select with have a dark 
border designating it as the master shape; the 

others will have lighter borders. 
 Drag box around shapes or 
 Shift-click shapes to add/remove from list 

 Select the Home tab, Arrange group, Align button  

 Select alignment type 

  

For shortcut to add new shapes, see Connecting Shapes below 
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 Adjust Shape Spacing 

 You can adjust the space between shapes 

 Select shapes to space  

 Drag box around shapes or 
 Shift-click shapes to add/remove from list 

 Select the Home tab, Arrange group, Position button 

 Select distribution type 

 Shapes will evenly distribute between left-most and 
right-most shapes or top-most and bottom-most 
shapes) 

 

 

 Adding Text to Shapes 

 Click the shape to label  
 Type text for shape 

 Visio will automatically zoom in on the shape to 
make entering text easier 

 Visio will automatically wrap text that does not fit in 

the current shape 
 Press Enter to move to the next line of the label 

before word wrap does 

 Adjust font and size for text 
 Drop down list of fonts (Home tab, Font group) to 

change character appearance 
 Drop down size list to change size of characters 

 Drop down the color list to change the text color 
 To change the appearance of only a part of the label, 

select the desired text, then change its appearance. 

 Click outside of shape to lock in text  
(Visio will automatically zoom back out if it zoomed in) 

(Caution: if you click on another shape before allowing 
Visio to zoom out, Visio will forget to zoom back out) 
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 Connecting Shapes 

Option 1 

 The quickest way to connect shapes is to use the 
connection arrows.  

 These arrows appear around a shape when the shape is 
selected and the mouse pointer is resting inside the shape. 

 Point to (but don’t click) a connection arrow to preview 
how the connection will appear. 

 Click to make the connection 
 

Tip: You can also use the connection arrows to add shapes to 
a diagram.  

 Point to (but don’t click) a connection arrow, then select 
the new shape you want from the list that appears.  

 If you wait a second a preview of the shape will appear. 

 
Option 2 

 If you need greater control of the connection, use the 

 tool in the Home tab, Tools group. 

 Touch the middle of a shape. Its borders will change 
color. Drag to the shape you want to connect to. A dotted 

line will appear previewing the connection. 

 Turn off the Connector Tool by selecting the 

 in the Home tab, Tools group. 
 

Option 3 

 The connector tool (see Option 2) provides even greater 
control of connections. 

 Place your mouse over any one of the small black dots 
that appear on the side of the shapes (usually located on 

the middle sizing arrows). A small box should appear.  

 Drag to the connector dot on the second shape till a green 

box appears, then release the mouse button. Visio will 
automatically connect the shapes in an appropriate 

manner. 

 Turn off the Connector Tool by selecting the 

 in the Home tab, Tools group. 
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 Adjusting Connectors 

 Easier if you use the Pointer Tool  

 Moving end points 

 Select the connector (click it) 
 Point to an endpoint. End points appear as green 

boxes at each end of the connector. 

 Drag the endpoint to a different connection point 
(dot) on this shape or a different shape. 

 Deleting a connector 
 Select the connector (click it) 
 Press the delete key on the keyboard. 

 Changing connector appearance 
 Select the connector (click it) 

 Select the  button in the Home tab, Shape 
Styles group. 

 Change the line weight, line color, line pattern, 
and/or arrows as necessary using the items that 
appear.   

Tip: Choose to display a dialog box that allows 
you to change many connector features in a window pane 

that appears on the right side of the window. 
Tip: You can also right-click a connection and format with the 

options on the popup menu. 
 This is probably the easiest way to convert a line that 

appears with right angles to a straight line 
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 Adding Line Labels 

 At this point, it often helps to zoom in to  (at least) 100% 

 The easiest way to add text to a connector is to select the 

connector and type.  
 If you want to add floating text (not necessarily on a 

connector) see below. 

 Select the connector (click it) 

 Begin typing the text you want to appear on the 

connector. Press Enter if you want multiple line labels. 

 Use the Home tab, Font group to change the size, color, 

font of the label (make sure the connector is still selected) 

 To move the text, point to the yellow square in the text 

and drag it to a new location. 
NOTE: you can even drag the text off the line. 

This label will always be connected to the line. If you 
move the connector or its endpoints, the text will stay 
near the connector. 

 

 

 Adding Floating Text 

 Just like in Microsoft Word, you use text boxes to add 
floating text to a Visio diagram. 

 Click the Text Box button in the Insert tab, Text 
group. 

 Drag a box on the screen that is the approximate 
size of the text box you want.  
 You can resize the text box later if you need to. 

 Type the text you want to appear. 

 With the text box selected, use the Home tab to change 

the appearance of the text or the text box itself (fill, line 
color, shadow, etc.) 
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 Multiple Page Flowcharts 

 Some flowcharts get quite large. Visio 2013 allows you to 
automatically make a diagram page bigger if you need 
more space vertically or horizontally. 

 Ensure the Auto Size button is selected in the 
Design tab (it usually is) 

 Drag a shape (or shapes) to any edge of the 
current drawing. 

 Visio will show a new page that you can drop 

your shapes on. 

 Page breaks appear to show how the diagram 

would print 
 

 

 Most of your flowcharts (after the first few) will include 
more than one event flowchart. Some, you’ll be able to 

combine onto one page. As they get larger, you can put 
each event flowchart into a separate tab to make them 
easy to locate.   

 Visio treats pages like Excel treats workbooks.  Visio 
files can contain more the one page.   

 Each page is represented by a tab at the bottom of the 
window.  

 

 To insert a new page in a file: 
 

 Click the New Page button  to the right of the last  
tab  

   or 
Right-click any tab and choose Insert  
   or 

 Select the Insert tab, Blank Page button 
 

 To make your pages easier to manage, you’ll need to 
rename the tab.  To rename a tab: 

 Double-click the tab and type in the new name 
   or 
 Right-click the tab, choose Rename and type in the 

new name. 
 

 



Instructor’s Notes Programming Logic - Beginning Using Visio 

 

  Visio: Page 9 of 10 

Notes Activity 

 Sprucing Up Your Drawing 

Like all Microsoft Office products, Visio comes with design 
templates that allow you to quickly add a little flair to your 
diagrams. 

 

 Select the Design tab. 

 Touch (but don’t click) any of the buttons in the Themes 
group to see the effect on your diagram.  

 Click the Theme to implement it. 
 

 Visio also includes Borders and Titles. Use this feature to 
add your name and any other information in a stylish 

way. 

 Select the button in the Design tab, 
Backgrounds group. 

 Select the style of border you’d like. There isn’t a 
live preview feature for this, so you’ll have to click 

the border style to see it. 
Tip: Right-click the border to designate whether it 
should be used for the current page or all pages. 

 It’s not real obvious, but to change the word Title, 
double-click it and simply start typing 

 

 

 Saving a Visio Drawing 

I suggest you save often. If you don’t want to redo it, save it. 

 

 Click the Save button  on the Quick Access toolbar or 

choose the File tab and choose Save or press Ctrl-S 

 Specify the location and name for your diagram. 

 Click the Save button 
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 Printing a Visio Drawing 

 Ask yourself—do I really need to print this? If you’re not 
sure (or the answer is no) skip the rest of this. 

 Save the drawing first (see above) 

 Select the File tab 

 Select Print 
 The Print window includes a preview of the 

document 

 If the preview looks OK, click the Print button 
in the Print Preview tab, Print group. 

 
 

 Click the Back button to return to Visio  
 

 

 


